WordPress 5.0 Beta 1

O WordPress 5.0 Beta 1 já está disponível!

Esta versão ainda está em desenvolvimento, portanto não recomendamos seu uso em ambientes de produção. Considere criar um site de testes para testá-la e, se você já está usando um site de testes, tenha certeza de atualizar o plugin Gutenberg para a versão 4.1.

Existem duas formas de testar o WordPress 5.0 beta: com o plugin WordPress Beta Tester (você deve usar “bleeding edge nightlies”) ou você pode baixar a versão aqui (zip).

O lançamento do WordPress 5.0 está previsto para 19 de novembro e precisamos da sua ajuda para que isso aconteça. Aqui estão alguns dos itens mais importantes para testar, de modo que possamos encontrar tantos erros quanto possível nas próximas semanas.

O editor de blocos

O novo editor de blocos Gutenberg agora será o editor de posts padrão!

O editor de blocos fornece uma experiência de edição moderna e rica em mídias. Você pode criar conteúdos flexíveis e bonitos sem escrever uma linha de código ou você pode mergulhar nas modernas APIs de programação que o editor de blocos fornece.

Mesmo antes de instalar o WordPress 5.0, você pode testar o editor de blocos aqui.

Claro, sabemos que nem todo mundo está preparado para essa mudança ainda. Se esse for o seu caso, você pode instalar o plugin Editor Clássico agora, e ele manterá o editor com que você já está familiarizado como padrão, mesmo que você atualize para o WordPress 5.0.

Twenty Nineteen (2019)

Junto com o novo editor de blocos, temos um novo tema padrão, chamado Twenty Nineteen, que usufrui de todas as vantagens fornecidas pelo editor de blocos.

Você pode saber mais sobre o Twenty Nineteen neste post de apresentação e acompanhar seu desenvolvimento através do repositório no GitHub.

Temas padrão

Claro, nós não poderíamos lançar uma nova e linda versão de um tema padrão e deixar todos os nossos temas antigos para trás. Atualizamos todos os temas desde o Twenty Ten, para que eles também fiquem bonitos no novo editor de blocos.

Como ajudar

Ajude-nos a traduzir o WordPress para o Português do Brasil! Um problema já conhecido: o autocompletar dos blocos não funciona com nomes que contenham caracteres não-latinos. Adicionar blocos através do sinal de adição funciona e este erro já está corrigido na versão 4.1 do Gutenberg. 🙂

Se acha que encontrou um erro, você pode publicá-lo na área Alpha/Beta do fórum oficial. Nós vamos adorar ouvir você! Se você está apto a escrever um relatório de um erro que outras pessoas podem reproduzir, envie-o para o WordPress Trac (em inglês), onde você também pode encontrar uma lista dos erros já conhecidos.


Corrigindo erros pequenos
Indo de um por um
Você consegue mudar o mundo

Fonte: Wordpress Brasil

Anterior

Próximo

Enviar Comentário

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *